summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJames E. Blair <corvus@gnu.org>2009-07-26 19:26:45 -0700
committerJames E. Blair <corvus@gnu.org>2009-07-26 19:26:45 -0700
commit1a32a7e36c7e1d732c72acb30b8a6a6dc2fc7651 (patch)
treeb77ac5272b01f4bdc5657ff2dd07e96f0a4f892d /setup.py
Initial checkin (TG 2.0).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ca3cb4f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,49 @@
1# -*- coding: utf-8 -*-
2try:
3 from setuptools import setup, find_packages
4except ImportError:
5 from ez_setup import use_setuptools
6 use_setuptools()
7 from setuptools import setup, find_packages
8
9setup(
10 name='quoins',
11 version='2.0',
12 description='',
13 author='',
14 author_email='',
15 #url='',
16 install_requires=[
17 "TurboGears2 >= 2.0b7",
18 "Catwalk >= 2.0.2",
19 "Babel >=0.9.4",
20 #can be removed iif use_toscawidgets = False
21 "toscawidgets >= 0.9.7.1",
22 "zope.sqlalchemy >= 0.4 ",
23 "repoze.tm2 >= 1.0a4",
24 "tw.tinymce >= 0.8",
25 "python-openid >= 2.2.4",
26 "MySQL-python >= 1.2.3c1",
27 "repoze.what-quickstart >= 1.0",
28 ],
29 setup_requires=["PasteScript >= 1.7"],
30 paster_plugins=['PasteScript', 'Pylons', 'TurboGears2', 'tg.devtools'],
31 packages=find_packages(exclude=['ez_setup']),
32 include_package_data=True,
33 test_suite='nose.collector',
34 tests_require=['WebTest', 'BeautifulSoup'],
35 package_data={'quoins': ['i18n/*/LC_MESSAGES/*.mo',
36 'templates/*/*',
37 'public/*/*']},
38 message_extractors={'quoins': [
39 ('**.py', 'python', None),
40 ('templates/**.mako', 'mako', None),
41 ('templates/**.html', 'genshi', None),
42 ('public/**', 'ignore', None)]},
43
44 entry_points="""
45 [paste.paster_command]
46 openid = quoins.command:OpenIDCommand
47 blog = quoins.command:BlogCommand
48 """,
49)