diff options
author | Monty Taylor <mordred@inaugust.com> | 2016-10-13 10:39:41 -0500 |
---|---|---|
committer | Monty Taylor <mordred@inaugust.com> | 2016-10-13 10:39:41 -0500 |
commit | 644d93f4d632c302cc8cd8ef5c465acfa4e478d5 (patch) | |
tree | f1fae88cdafc423137507b1a8c0f16051d6b7c2a /setup.py |
Initial Cookiecutter Commit.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py new file mode 100644 index 0000000..056c16c --- /dev/null +++ b/setup.py | |||
@@ -0,0 +1,29 @@ | |||
1 | # Copyright (c) 2013 Hewlett-Packard Development Company, L.P. | ||
2 | # | ||
3 | # Licensed under the Apache License, Version 2.0 (the "License"); | ||
4 | # you may not use this file except in compliance with the License. | ||
5 | # You may obtain a copy of the License at | ||
6 | # | ||
7 | # http://www.apache.org/licenses/LICENSE-2.0 | ||
8 | # | ||
9 | # Unless required by applicable law or agreed to in writing, software | ||
10 | # distributed under the License is distributed on an "AS IS" BASIS, | ||
11 | # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or | ||
12 | # implied. | ||
13 | # See the License for the specific language governing permissions and | ||
14 | # limitations under the License. | ||
15 | |||
16 | # THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT | ||
17 | import setuptools | ||
18 | |||
19 | # In python < 2.7.4, a lazy loading of package `pbr` will break | ||
20 | # setuptools if some other modules registered functions in `atexit`. | ||
21 | # solution from: http://bugs.python.org/issue15881#msg170215 | ||
22 | try: | ||
23 | import multiprocessing # noqa | ||
24 | except ImportError: | ||
25 | pass | ||
26 | |||
27 | setuptools.setup( | ||
28 | setup_requires=['pbr'], | ||
29 | pbr=True) | ||